<thead id="thpzt"><noframes id="thpzt">
<progress id="thpzt"><noframes id="thpzt"><th id="thpzt"></th>
<ruby id="thpzt"><noframes id="thpzt"><ruby id="thpzt"></ruby>
<progress id="thpzt"></progress>
<span id="thpzt"><noframes id="thpzt"><span id="thpzt"></span>
<progress id="thpzt"><noframes id="thpzt">
<th id="thpzt"><noframes id="thpzt"><span id="thpzt"><noframes id="thpzt"><strike id="thpzt"></strike><strike id="thpzt"></strike>

dhcp是什么意思 dhcp是什么意思開不開

導讀:今天主要向大家介紹有關DHCP的內容,有需要的朋友可以收藏一下!

一、 DHCP概述

1、DHCP

Dynamic Host Configuration Protocol 動態主機配置協議,是一種提供傳輸配置信息到主機的方法。

客戶機使用UDP68端口發送請求報文,服務器使用UDP67端口回應,給客戶機提供ip地址以及其它相關信息,如網絡掩碼、路由、DNS服務器地址等?;贑lient-Server模式,信息格式與BOOTP類似。

2

手工配置IP地址的優缺點

(1)缺點:

配置繁瑣;

容易導致IP地址沖突;

可移動性較差;

安全性得不到保障。

干貨|什么是DHCP?這些我們應該知道

(2)優點:

配置簡單;

可移動性較好;

相對安全。

3、地址分配方式

自動分配— DHCP分配永久的IP地址給主機

動態分配— DHCP分配給客戶機一個地址的租約(或直到主機聲明放棄地址)

手動分配— 主機IP地址由管理員指定

注:僅僅動態分配有地址回收機制。

干貨|什么是DHCP?這些我們應該知道

二、DHCP常見術語

DHCP client:DHCP 客戶機,通過DHCP 獲得網絡參數的主機。

DHCP server:DHCP 服務器,為DHCP client提供網絡參數的主機。

BOOTP relay agent:BOOTP 中繼代理,在DHCP 服務器和DHCP 客戶之間傳送DHCP 消息的主機或路由器。

DHCP relay agent:DHCP 中繼代理,在DHCP 服務器和DHCP 客戶之間傳送dhcp 消息的主機或路由器。

binding:綁定、封裝。將收集的配置參數(至少包括一個ip地址),封裝并分配給客戶機。這個動作是由服務器處理的。

干貨|什么是DHCP?這些我們應該知道

三、Dhcp server配置步驟

1. 啟動/關閉DHCP服務器功能

2. 配置DHCP地址池

(1) 創建/刪除DHCP地址池

(2) 配置動態DHCP地址池的參數

(3) 配置手工DHCP地址池的參數

3. 啟動記錄地址沖突的日志功能

4. 配置發ping包的個數和超時時間

Switch(Config)# service dhcp

Switch(Config)#ip dhcp pool A

Switch(dhcp-A-config)#network 10.16.1.0 24

Switch(dhcp-A-config)#lease 3

Switch(dhcp-A-config)#default-route 10.16.1.200 10.16.1.201

Switch(dhcp-A-config)#dns-server 10.16.1.202

Switch(dhcp-A-config)#netbios-name-server 10.16.1.209

Switch(dhcp-A-config)#exit

Switch(Config)#ip dhcp excluded-address 10.16.1.200 10.16.1.210

Switch(Config)#ip dhcp excluded-address 10.16.2.200 10.16.2.210

Switch(Config)#ip dhcp pool B

Switch(dhcp-A1config)#host 10.16.1.210

Switch(dhcp-A1-config)#hardware-address 0003.2223.dcab

Switch(Config)# ip dhcp conflict logging//*地址沖突缺省啟用

Switch(Config)#ip dhcp ping timeout 1000 //*ping超時缺省500ms

Switch(Config)#ip dhcp ping packets 5//*缺省發ping包個數為2

干貨|什么是DHCP?這些我們應該知道

四、Dhcp中繼

在大型的網絡中,可能會存在多個子網。DHCP客戶機通過網絡廣播消息獲得DHCP服務器的響應后得到IP地址。但廣播消息是不能跨越子網的。因此,如果DHCP客戶機和服務器在不同的子網內,客戶機還能不能向服務器申請IP地址呢?

這就要用到DHCP中繼代理。

DHCP中繼代理實際上是一種軟件技術,安裝了DHCP中繼代理的計算機稱為DHCP中繼代理服務器,它承擔不同子網間的DHCP客戶機和服務器的通信任務。

1DHCP 中繼配置任務序列如下:

啟動 DHCP 中繼

配置 DHCP 中繼轉發 DHCP 廣播報文

說明:網絡中已存在DHCP Server,Vlan 20內PC的IP地址通過DHPC Relay方式獲得。

組網圖:

干貨|什么是DHCP?這些我們應該知道

2、DHCP Server的配置

switch(config)#service dhcp 開啟dhcp服務

switch(config)#ip dhcp pool vlan20 創建dhcp地址池

switch(dhcp-vlan20-config)#network 10.1.2.1 24 dhcp的地址范圍

switch(dhcp-vlan20-config)#default-router 10.1.2.1 dhcp網關

switch(dhcp-vlan20-config)#exit

干貨|什么是DHCP?這些我們應該知道

3、DHCP Relay的配置

switch(config)#service dhcp 開啟dhcp服務

switch(config)#ip forward-protocol udp bootps 開啟dhcp中繼轉發udp廣播報文

switch(config)#vlan 10

switch(config-Vlan10)#ip address 10.1.1.2 255.255.255.0 配置IP地址switch(config-Vlan10)#exitswitch(config)#vlan 20

switch(config-Vlan20)#ip address 10.1.2.1 255.255.255.0 配置IP地址switch(config-Vlan20)#ip help-address 10.1.1.1 指定dhcp中繼轉發UDP報文的目的地址

switch(config-Vlan20)#exit

干貨|什么是DHCP?這些我們應該知道

五、Dhcp Snooping

DHCP Snooping 功能指交換機監測 DHCP CLIENT 通過 DHCP 協議獲取 IP 的過程。它通過設置信任端口和非信任端口,來防止 DHCP 攻擊及私設 DHCP SERVER。

從信任端口接收的 DHCP 報文無需校驗即可轉發。典型的設置是將信任端口連接 DHCP SERVER 或者 DHCP RELAY 代理。非信任端口連接 DHCP CLIENT,交換機將轉發從非信任端口接收的 DHCP 請求報文,不轉發從非信任端口接收的 DHCP 回應報文。

如果從非信任端口接收DHCP 回應報文,除了發出告警信息外,并可根據設置對該端口執行相應的動作,比如shutdown、下發 blackhole。

如果啟用了 DHCP Snooping 綁定功能,則交換機將會保存非信任端口下的 DHCP CLIENT 的綁定信息,每一條綁定信息包含該 DHCP CLIENT 的 MAC地址、 IP 地址、租期、 VLAN 號和端口號,這些綁定信息存放于 DHCP Snooping 的綁定表。

干貨|什么是DHCP?這些我們應該知道

如上圖:

1、Mac-AA 設備為正常用戶,連接在交換機非信任端口 1/1 上,其通過 DHCP Client獲得 IP 1.1.1.5;

2、DHCP Server 和 GateWay 分別連接在交換機的信任端口 1/11 ; 1/12 上;惡意用戶 Mac-BB 連接在非信任端口 1/10 上,試圖偽裝 DHCP Server(發送 DHCPACK)。

3 、在交換機上設置 DHCP snooping 將能有效發現并阻止這種網絡攻擊。

干貨|什么是DHCP?這些我們應該知道

交換機配置為:

switch#

switch#config

switch(config)#ip dhcp snooping enable 開啟dhcp偵聽功能

switch(config)#interface ethernet 1/11

switch(Config-Ethernet1/11 )#ip dhcp snooping trust 設置信任端口

switch(Config-Ethernet1/11 )#exit

switch(config)#interface ethernet 1/12

switch(Config-Ethernet1/12)#ip dhcp snooping trust 設置信任端口

switch(Config-Ethernet1/12)#exit

switch(config)#interface ethernet 1/1 -10

switch(Config-Port-Range)#ip dhcp snooping action shutdown 其余端口收到dhcp服務時直接阻塞端口

switch(Config-Port-Range)#

公眾號:安徽思恒信息科技有限公司,了解更多技術內容……

【版權聲明】嘰嘰歪歪吧提醒您:請在瀏覽本網站關于《dhcp是什么意思 dhcp是什么意思開不開》信息時,請您務必閱讀并理解本聲明。本站部分內容以及圖片來源于商家投稿和網絡轉載,如網站發布的有關的信息侵犯到您的權益,請及時與我們取得聯系,郵箱:20451 17252#qq。com,我們會尊重您的決定并當天作出刪除處理。

(0)
上一篇 2022年5月8日 17:05:04
下一篇 2022年5月8日 17:25:04

相關推薦

  • 象征和比喻的區別(如何區分象征和比喻)

    象征和比喻的區別(如何區分象征和比喻)有些東西,我們習以為常,以為完全知道,其實并不完全理解?,F在我們以“比喻”和“擬人”為切人點來盤點一下現代文閱讀中一些看似明晰而實質上容易混淆的概念。比喻和擬人,這個我們小學三年級就開始接觸的概念,不知

    2022年3月2日
    14
  • 穿越劇禁播的原因有哪些 穿越劇過審

    穿越劇禁播的原因有哪些(穿越劇過審)電視劇《慶余年》終于在時間正式上線,這部劇是根據小說《慶余年》改編的,因為原著小說是穿越題材,現在穿越劇被禁確因為編劇大腦洞變為科幻劇三分鐘實力過審?!稇c余年》正式上線之后,大家才發現,編劇王倦只是給這部

    2022年5月7日
    0
  • 蘇寧國際的東西是正品嗎(蘇寧易購海外旗艦店靠譜嗎)

    蘇寧國際的東西是正品嗎(蘇寧易購海外旗艦店靠譜嗎)日前,有媒體報道,嘉興的小楊在蘇寧國際購買的匡威鞋經第三方鑒定為假貨。9月9日,蘇寧國際官方微博曬出來自歐洲匡威品牌方的郵件回復,確認蘇寧國際的匡威鞋為正品。不僅如此,在蘇寧國際的這份聲明里

    2022年2月15日 ? 生活小知識
    15
  • 怎么實時同步微信聊天記錄嗎(微信聊天記錄實時上傳)

    怎么實時同步微信聊天記錄嗎(微信聊天記錄實時上傳)很多朋友因為工作需要,嫌棄使用手機聊比較麻煩,于是就在電腦上安裝了,但因為客戶端的不互通,導致很多消息不同步,錯過一些重要的消息,本期文章就教大家如何將手機和電腦的消息設置成同步。一、安裝電

    2022年2月26日
    12
  • 上班族適合做什么副業賺錢 上班族干什么副業賺錢

    上班族適合做什么副業賺錢(上班族干什么副業賺錢)點擊要知道,突然間失去工作,面對收入的不確定性,陷入收入來源的恐慌,并沒有用,只會徒增自己的煩惱。中年人,可以通過副業的形式增加可預見性收入,應對好危機。工資低養不活自己,這3種副業既不耽誤主

    2022年5月1日 ? 生活小知識
    1
  • 為什么全友用中纖板 全友中纖板用的什么膠

    為什么全友用中纖板(全友中纖板用的什么膠)黃女士提供的板材切面。 記者 楊潔規 攝株洲的黃女士撥打本報熱線反映,其在株洲石峰區銅鑼灣廣場的全友家居門店訂制了全房衣柜,商家買前宣傳說是實木的,但在裝修中發現并非實木,而是人造板。11月27日,

    2022年4月1日
    4
  • 免費錄屏軟件電腦(免費的錄屏軟件哪個好用)

    免費錄屏軟件電腦(免費的錄屏軟件哪個好用)這里是知科技app,如果覺得本文有用,歡迎【】我。聲明:【】+【點贊】= 有驚喜EV錄屏——免費高清無水印EV錄屏軟件(視頻錄制直播軟件)是一款不收費、不限時的高性能視頻錄制直播軟件。支持全屏錄制、

    2022年2月11日 ? 生活小知識
    16
  • 曾經心疼歌詞(曾經心痛原唱葉倩文)

    曾經心疼歌詞(曾經心痛原唱葉倩文)大家好,最近一直在聽一首老歌《曾經心疼》,無論是原唱還是翻版,都能聽出不同的感覺。聽到深處自然有感而發,下面就和大家一起分享一下我聽這首經典老歌的感受。老規矩先上歌詞:路上行人匆匆過沒有人會回頭看一眼我只是

    2022年3月16日 ? 生活小知識
    8
  • 怎么查找刪除微信聊天記錄(微信查已刪除的聊天記錄)

    怎么查找刪除微信聊天記錄(微信查已刪除的聊天記錄)更新、換手機、切換賬號、對話框不小心刪除...聊天記錄就沒了,有沒有辦法可以恢復呢?今天小編就來教大家聊天記錄備份和恢復的小技巧,看之前先點收藏!1.電腦聊天記錄備份如果你手機的聊天記錄沒了

    2022年2月24日 ? 生活小知識
    15
  • 胡歌車禍前后對比照片 胡歌助理張冕個人圖片

    胡歌車禍前后對比照片(胡歌助理張冕個人圖片)談起影視劇里的一股清流,不得不提起《瑯琊榜》中那個叫梅長蘇的瘦弱男子,他白衣舒展眉目從容,卻能在一個亂世撥弄風云,他雖手無縛雞之力,但他眼中心中似是有團烈火在燃燒。而用精湛的演技演出梅長蘇的人,就

    2022年4月30日 ? 生活小知識
    0

發表評論

登錄后才能評論
丰满熟妇乱子伦,久久精品国产亚洲AV蜜芽,13女下面粉嫩自慰喷白浆免费
<thead id="thpzt"><noframes id="thpzt">
<progress id="thpzt"><noframes id="thpzt"><th id="thpzt"></th>
<ruby id="thpzt"><noframes id="thpzt"><ruby id="thpzt"></ruby>
<progress id="thpzt"></progress>
<span id="thpzt"><noframes id="thpzt"><span id="thpzt"></span>
<progress id="thpzt"><noframes id="thpzt">
<th id="thpzt"><noframes id="thpzt"><span id="thpzt"><noframes id="thpzt"><strike id="thpzt"></strike><strike id="thpzt"></strike>
<蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <蜘蛛词>| <文本链> <文本链> <文本链> <文本链> <文本链> <文本链>